迅维网

查看: 11188|回复: 139
[乐虎app手机版经验]

震惊!一台一修苹果机竟将迅维笔记本组全部撂倒

    [复制链接]
发表于 2019-11-4 11:43:31 | 显示全部楼层 |阅读模式
震惊!一台一修苹果机竟将迅维笔记本组全部撂倒

       大家好,我是迅维实地笔记本科目2019年4月的学员,目前在迅维乐虎app手机版部工作
       最近接到一个客户的苹果笔记本,A1370,是个一修机,就是这个机器,把迅维笔记本组全给撂倒了(包括我在内乐虎app手机版部的两位,船长,月饼,阿林,这个阵容也算是豪华了),接下来我们就来看看这是怎么一个难修的故障吧。
拿到机器后,首先看一下故障说明:不开机。嗯,很简单的三个字,接下来上电,看一下电流的情况
截图201911041703381042.png

可以看到电流上到0.15就不动了,对于这款笔记本来说电流低了点,应该是有电压还没有出来,有了这么一个方向后,接下来就拆机吧。
        在褪下其青涩的外衣后,它便赤裸裸的展现在了我的面前,便急不可耐的观察起了它的身体,欸嘿,发现有一个电容发霉了,顿时心中一阵窃喜,看来这次是要秒杀了
截图201911041704154040.png
截图201911041706111700.png
截图201911041706454130.png


        迅速将其清理干净,焊盘处理好,同时观察出这个电容是旁边的电源芯片所使用的,为了防止是自举电容,测量两个焊盘对地值,发现一端接地,是个滤波电容,不补问题也不大,但是这个电容离芯片这么近,为了稳点,还是补一个上去吧,便随手从料板上摘了一颗差不多大小的电容补了上去。
        接下来,再次上电,故障依旧,还是上电到0.15就不动了,看来秒杀是不可能秒杀了,还是一步步的查条件吧,打开图纸和点位,找到刚刚那个发霉的电容
截图201911051414474397.png

可以看到是内存供电芯片的REFIN脚的滤波电容,也就是用来设定输出电压的。再次上电,测量内存供电是否正常,无输出,看来问题还是出在内存供电这块。
        这个供电芯片的工作流程是这样的
截图201911041707297537.png


        那么现在没有内存主供电的输出,我们就要查芯片的供电,开启,电压设定。测量结果供电(5V),开启(3.3V),电压设定脚(1.5v)以上测量结果均是正常值,那么芯片应该已经工作了,用示波器测量上管的G极,发现有几下波形
截图201911041707487468.png

测量下管G极,5V波形跳变几下后成为持续的5V高电平
截图201911041708019201.png

很典型的芯片保护状态,这时候就要重点测量反馈脚了,但是经过测量,电压反馈脚到电感也是通的,没有断路的情况,电压反馈应该是没有问题的,接下来测量一下是不是因为滤波不良引起的芯片保护,测量电感前端,有几下8v波形
截图201911041709431755.png

正常,电感后端却一点波形都没有,?这是什么奇怪的情况,难道大电感坏了,我入行了半年,还没有遇到过或者听说过一例大电感损坏的情况,万用表测量电感也是通的,电感的问题应该不大,还是再查查芯片吧。
把刚刚没查的和输出有关的脚位再查一下(MODE脚,TRIP脚),这两个脚是通过下拉电阻接地的,将这两个电阻卸下,测量其阻值没有发现异常。看来这两个脚也没有什么问题。改查的也都查了,没有发现问题,应该就是芯片的问题了。果断找到一模一样的料板,芯片换上,满怀信心的上电,结果还是原故障,顿时就懵了,这样一个简单的PWM电路,也没什么条件了啊。这时就乱了方寸,开始没头绪的乱换件,换了上下管,电感,故障还是依旧。没办法,只能发动乐虎app手机版界的绝世秘籍了,“换人”,首先是找到我们乐虎app手机版部的大师傅,一起探讨了一会儿也是没有什么头绪。大师傅over。
好在我们迅维人才济济,又找到船长,看看有没有什么新奇的思路,船长不亏是船长,瞬间就提供了很棒的思路,首先判断出这肯定是保护了,而这个电路的设计是电压通过芯片的反馈脚来检测,电流通过检流电阻将信号发到另一个独立的芯片来检流,
截图201911041709589366.png

按照电路分析,在芯片保护时,开启并没有掉,而检流芯片并没有别的手段可以让芯片保护,所以应该不是检测到过流,但是为了保险起见,让我先把检流电阻直连试一下,试过后,故障依旧,因为芯片的电压反馈检测点在检流电阻之后,摘掉检流电阻,让芯片得不到反馈,一般会导致芯片欠压保护,试着再次上电测量上下管g极的波形,看看又没有变化。
        测量结束后,果然有了发现,上管的波形还比不拆之前更加长了拆检流电阻后的上管G极
截图201911041710182521.png


拆检流后的下管g极
截图201911041711067301.png

拆检流电感前端
截图201911041711162553.png

拆检流电感后端
截图201911041711255444.png

         从上面的波形可以看的出来,自举是没有问题的,上下管的导通也是没有问题的,由于滤波电容都在检流电阻的后端,所以电感后端这个波形也是正常的,既然欠压保护时的波形是这样的,那么芯片应该是进入了过压保护的状态,但是在补上检流电阻恢复好电路之后,电感后端一点电压都检测不到,更不要说是过压了,一时间又陷入了困境,加上船长要上课,就只能搁置了下来,船长,over。
        不过船长在最后又提供了一个骚操作,外接一个内存供电出来看能不能正常工作,如果能正常工作,那肯定是前级的问题,死命修就完事儿了。拆掉供电芯片,上下管,飞好线,外接1.5v
截图201911041711388459.png

这次上电电流跑到了0.7A,已经有了平台复位,但是由于没有VTT供电,没有过内存。但是这是难不倒我的,用1.5v串联分压分出来一个0.75V接到主板上,再次上电,结果因为电阻选的大了点,0.75v带不起负载,还是档内存,但是到了这里,基本可以判断后极没有问题了,问题还是出在前级。
        过了一会儿,饼哥听说了这个消息,不可置信的说“不会吧,一个供电这么难修?”,随后我们便有幸的看到了饼哥亲自操刀修机。饼哥一上来就将内存供电芯片拆了下来,一个个引脚的测量是否有断线的异常情况,20个引脚测量完,并没有发现异常, MODE和TRIP的下拉电阻也测量了阻值,阻值也在正常范围内,装上芯片,上电测量供电、开启、、REFIN的电压波形完全正常,测量上管G极、下管G极、电感前端的波形,也得出了是保护了的结论,但是为什么保护了还是不清楚,更换了一个全新的供电芯片上去也是一切照常,同时双通道对比保护瞬间5V供电和开启开启信号的情况,供电和开启纹丝不动,当然结果也是没有什么发现,此时饼哥已经查了一个小时,由于饼哥还有要务缠身,同时为了整理一下思路,就先离开了,饼哥,over。
        再后来,阿林老师听说了这样的情况,也跑过来看了看,把上面的条件又测了一遍,当然也是没有发现异常,后来又提出了用示波器双通道对比测量芯片所有信号在保护时的动作,阿林老师也是个大忙人,没有太多时间在这里耗,不一会儿也离开了,阿林老师,OVER,此时修这个板子也已经修了多半天,思路也已经十分混乱,于是决定放空一下大脑,先将这个板子放下,明天再看它。
至此,迅维笔记本技术组,已经全体暂告OVER。[/co ...        
本帖为精华帖,如要查看隐藏内容,请支付0.5元给本帖作者。写帖不易,请多支持。立即支付

评分

参与人数 11下载分 +42 金币 +33 收起 理由
+ 5
+ 5
楼主总是在牛A与牛C之间徘徊
+ 2
+ 2
看不懂,但是确实吸引人。
+ 2
+ 2
给愿意分享经验的人加分!
zpz
+ 5
+ 5
淡定的男人最成功,淡定的人生不寂寞
+ 5
+ 5
老司机!双击666+关注.....
+ 2
期待答案
+ 2
给愿意分享经验的人加分!
+ 5
+ 5
思路清晰
+ 2
+ 2
精品文章
+ 2
老司机!双击666+关注.....

查看全部评分

本文由 yang947188327 原创或被授权转载制作,其他机构或个人未经许可严禁转载。
发表于 2019-11-4 17:23:33 | 显示全部楼层
这个故障,虽然我们全体over,但还是挺开心的,我也学到了东西!
很好的故障,给我上了一课,这是以前从来没有认识到的问题
大家踊跃发言,是哪里问题?
为什么?重点是为什么?

已更新。

回复 支持 2 反对 0

使用道具 举报

发表于 2019-11-4 17:41:32 | 显示全部楼层
腐蚀还是要围绕腐蚀位置来修,怀疑换的那个电容规格参数不符,或者芯片周围还有腐蚀断线包括芯片地和共地.

点评

看你们解释的头头是道 ,佩服佩服。。。。。。。。。。。。。。。。高手  详情 回复 发表于 6 天前
迅芯经常看到你帮别人分析解答问题 有可能是这电容  详情 回复 发表于 7 天前
我都没敢把原理框图发出来,你小子点评的那么直白  详情 回复 发表于 7 天前
C7316在芯片应用中来说是个精密的电容,0.01UF,误差值10%.再看前面分压电阻阻值可不小. 怼个容量大的电容上去后,形成了RC延时,弱电流的VREF分压对电容充电,造成S5到来,REFIN还没达到正常值.  发表于 7 天前

评分

参与人数 13下载分 +46 金币 +50 收起 理由
+ 2
老司机!双击666+关注.....
+ 5
+ 5
老司机!双击666+关注.....
+ 2
+ 2
给愿意分享经验的人加分!
+ 5
+ 5
给愿意分享经验的人加分!
+ 5
+ 5
正解!估计是这吊毛电容参数错了导致的。
+ 2
+ 2
你小子把我发出来的那段英文解释的那么清楚做什么,哈哈
+ 5
+ 5
+ 2
精品文章
+ 5
+ 5
老司机!双击666+关注.....
+ 5
精品文章

查看全部评分

回复 支持 14 反对 0

使用道具 举报

发表于 2019-11-4 17:55:02 | 显示全部楼层
电容能随便代换么。。。 随手拆一个补上去,可不把老司机给整翻车咯 所以本来的秒杀故障变成人为故障了

评分

参与人数 2下载分 +10 金币 +10 收起 理由
+ 5
+ 5
进水机,始终围绕进水的位置去修,基本不会错!!
+ 5
+ 5
给愿意分享经验的人加分!

查看全部评分

回复 支持 3 反对 0

使用道具 举报

发表于 2019-11-4 13:16:09 | 显示全部楼层
标题党举报你

点评

更新了  发表于 2019-11-4 17:23
回复 支持 2 反对 0

使用道具 举报

发表于 2019-11-5 21:09:43 来自迅维网APP | 显示全部楼层
jxz2ww 发表于 2019-11-05 19:47
  为什么不把    原因  发论坛里   还 发 群里       没个人都 这样吊人胃口 的话   。论坛 就 基本废了 有违背 论坛的宗旨吧!~~~~~

不是说了嘛,11号群内公布,12号更新,因为此故障确实平时不会引起注意,所以叫大家先发言猜猜看的。个人认为算是变相的活跃气氛吧。

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-5 13:59:52 | 显示全部楼层
本帖最后由 极致科技 于 2019-11-6 16:36 编辑

看这段文字
ThePGOOD start-up delay is 2.5 ms after S5 is asserted to high. Note that the time constant which is composed ofthe REFIN capacitor and a resistor divider needs to be short enough to reach the target value before PGOODcomparator enabled
手册里明确说明电阻和电容组成的............延时...........,所以...............自行理会吧。

评分

参与人数 2下载分 +10 金币 +10 收起 理由
+ 5
+ 5
淡定的男人最成功,淡定的人生不寂寞
+ 5
+ 5
给愿意分享经验的人加分!

查看全部评分

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-5 00:37:18 来自迅维网APP | 显示全部楼层
我猜想还是发霉电容这里的问题,老司机们也有翻车的时候,这贴写的吊胃口啊

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-4 22:16:04 来自迅维网APP | 显示全部楼层
我只看那发霉的电容边上两个电阻其中一个肯定有问题,另外你换的电容必须是参数相同才行,因为VTT过载同样会保护。

评分

参与人数 2下载分 +2 金币 +2 收起 理由
+ 2
精品文章
+ 2
我也觉得是

查看全部评分

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-4 20:49:02 来自迅维网APP | 显示全部楼层
好像没看到测REFIN的电压值是否正常

点评

电压正常,波形稳定  详情 回复 发表于 2019-11-5 06:29
回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-4 18:13:29 | 显示全部楼层
电容没换对,我认为

评分

参与人数 1下载分 +5 金币 +5 收起 理由
+ 5
+ 5
精品文章

查看全部评分

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-4 12:26:52 | 显示全部楼层
搁这写无字天书呢

点评

更新了。xiongdai  发表于 2019-11-4 17:24
回复 支持 反对

使用道具 举报

发表于 2019-11-4 12:35:10 | 显示全部楼层
将内容发出来看看,看看是什么问题,都将迅维的大神们都摞倒了,不相信这是真的?

点评

我也从这个案例学习到了东西  发表于 2019-11-4 17:23
回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:11:26 | 显示全部楼层
修好没有?

点评

被他修好了  发表于 2019-11-4 17:23
回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:30:36 | 显示全部楼层
震惊,终于得见庐山真面目。

回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:36:09 | 显示全部楼层
我见过MOS管不良导致不出供电的,也是可以正常导通,有时候甚至可以亮机一整天,你看看是不是MOS管不良

回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:45:33 | 显示全部楼层
坐等结果   让我们学习学习

回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:56:08 | 显示全部楼层
  是个难题,好像思路跑偏了

回复 支持 反对

使用道具 举报

发表于 2019-11-4 17:59:15 | 显示全部楼层
没完呢,等他们有空了就分分钟秒杀了

回复 支持 反对

使用道具 举报

发表于 2019-11-4 18:12:05 | 显示全部楼层
各种奇葩问题都是人的问题 最后还是那个发霉的电容问题         

评分

参与人数 1下载分 +5 金币 +5 收起 理由
+ 5
+ 5
精品文章

查看全部评分

回复 支持 1 反对 0

使用道具 举报

发表于 2019-11-4 18:13:34 | 显示全部楼层
坐等结果  学习中!

回复 支持 反对

使用道具 举报

发表于 2019-11-4 18:19:21 | 显示全部楼层
大电感坏的我见过

回复 支持 反对

使用道具 举报

发表于 2019-11-4 18:51:53 来自迅维网APP | 显示全部楼层
都是老司机飙车,实习油门当刹车踩的,作为菜鸟表示刚想踩油门结果踩了刹车的在原地观望吃瓜

回复 支持 反对

使用道具 举报

发表于 2019-11-4 19:31:03 来自迅维网APP | 显示全部楼层
有时候觉得理论学的太多,会涨知识。但是,总有那么些主板会给你上一课期待揭秘

回复 支持 反对

使用道具 举报

发表于 2019-11-4 19:35:55 来自迅维网APP | 显示全部楼层
换板啊
等什么

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则